Cisco Dhcp


Tagek: Cisco, Linux,
Írta: toshy
Publikálva: 2008-09-12 12:11:24

Egy rövid iromány arról, hogy hogyan csináljunk dhcp-t CISCO-n.

Két szituáció szeretnék bemutatni:

1. Van egy router egy switch , 2 darab VLAN, a router-nek egy egy interface-e benne egy egy VLAN (hálózatban) .

valahogy így:



Van akkor a VLAN10 a 10.1.10.0/24 -es hálózattal, valamint a VLAN20 a 10.1.20.0/24 -es hálózattal. Nem térnék ki arra, hogy a switch-en hogyan kell konfigurálni, a portokon a VLAN -t hiszen már beszéltem róla az oldalon. A router-en pedig íme így néz ki a 2 interface.

interface FastEthernet0/0
  ip address 10.1.10.1 255.255.255.0
  duplex auto
  speed auto
!
interface FastEthernet0/1
  ip address 10.1.20.1 255.255.255.0
  duplex auto
  speed auto
!


A DHCP konfigurációt a következő képen csináljuk. Először is létre hozunk egy “pool”-t, “global” konfigurációs módban.

Router(config)#ip dhcp pool 10dhcp



A pool neve “10dhcp” lett, és be kerültünk a dhpc pool-nak a konfigurációs módjába. Be írjuk a pool-hoz tartozó hálózatot, és a defualt gateway-t.

Router(dhcp-config)#network 10.1.10.0 255.255.255.0

Router(dhcp-config)#default-router 10.1.10.1



Szintén beírhatjuk opcionálisan a különböző dhcp opciókat, például DNS szervert, vagy MAC address-hez rendelt fix IP címeket. Exit paranccsal kilépünk.

Ki kell exclude-olni a FIX címeket (Routerek, Printerek, …stb)

Router(config)#ip dhcp excluded-address 10.1.10.1 10.1.10.25



Tehát a DHCP szerverünk a 10.1.10.0 -ás hálózatban 26 tól kezd IP címeket osztani. Készvan megcsináljuk a 20-as VLAN-ak is, és a végén a DHCP konfiguráció így néz ki:

ip dhcp excluded-address 10.1.10.1 10.1.10.25
ip dhcp excluded-address 10.1.20.1 10.1.20.25
!
ip dhcp pool 10dhcp
  network 10.1.10.0 255.255.255.0
  default-router 10.1.10.1
!
ip dhcp pool 20dhcp
  network 10.1.20.0 255.255.255.0
  default-router 10.1.20.1
!


2. Második eset amikor nem bízzuk a CISCO-ra a DHCP-t hanem egy szerver csinálja, azt most mindegy hogy milyen, lehet Windows-on Linuxon, Unix-on…. stb. Marad a 2 VLAN, IP címek.

valahogy így:



A router a trunk kapcsolattal kell a hálózatok közötti route-oláshoz (erre való egy router) , Be került egy szerver a 10.1.1.5 -ös címmel. Szintén nem szeretném megint csak leírni hogyan kell ilyenkor sub interface-eket csinálni a router-en, hiszen már erről is írtam, de ami lényeges, hogy a router-en a subinterface konfigurációs módjában, meg kell adni egy olyan parancsot hogy:

Router(config-if)#ip helper-address 10.1.1.5



És ezt minden subinterface-hez meg kell adni.

A szerver ilyenkor megnézi hogy melyik hálózatból jött a kérés, és abból a pool-ból osztja ki a címet. Nem írok szerver konfigurációt egyrészt azért mert mint említettem, sokféle létezik, másrészt pedig azért mert rá jöttem, hogy csinálok egy újabb írást egy konkrét példáról.

Mégpedig az én DHCP-s megoldásomról. Meg kell említenem, hogy ebben a redundancia dologban ami a DHCP szolgáltatást illeti nem igazán megbízható a CISCO megoldása. Hiszen úgy csinálják a redundanciát hogy felveszik ugyan azt a poolt két routere, és ip helper addres-ként megadni egymás után mind a kettő routert. Ezek után az egyik router-en a pool-ból ki kell exclude-olni a pool egyik felét, a másik router-en pedig ugyanabban a pool-ban a másik felét. Ha nem értenék hozzá akkor is érdekesnek hallatszana ez a megoldás, és úgy érezném hogy a redundancia szót nem igazán érdemli meg.

Egy komolyabb hálózatban ahol van ~1000 végpont, és nagy hangsúlyt fektetnek a redundanciára ott ezt a CISCO-féle DHCP szolgáltatást semmi kép sem ajánlanám. És akkor erre hoznék egy majdani írásomban példát.

Szólj hozzá

Hozzászólások(0)